Список форумов AmiSite.ru AmiSite.ru
Форум по Ами
 FAQ  •  Поиск  •  Пользователи  •  Группы   •  Регистрация  •  Профиль  •  Войти и проверить личные сообщения  •  Вход
 Неправильное отображение цифр в настройках параметров Следующая тема
Предыдущая тема
Начать новую тему  Ответить на тему
Автор Сообщение
Convergence



Зарегистрирован: 15.02.2017
Сообщения: 36

СообщениеДобавлено: Сб Май 12, 2018 12:50 pm Ответить с цитатой Вернуться к началу

Здравствуйте уважаемые форумчане!

Столкнулся с небольшой проблемой которая хоть и никак не сказывается на работе индикатора, но периодически задевает мои эстетические чувства. Дело в том, что в настройках параметров индикатора, например:

Var = Param("V", 0.05, -1, 1, 0.01);

0 отображается как -2.23517e-008
0.01 отображается как 0.00999998

все остальные цифры отображаются как положено, как поправить вывод этих цифр?
Посмотреть профиль Отправить личное сообщение
000
Site Admin


Зарегистрирован: 10.12.2007
Сообщения: 8457

СообщениеДобавлено: Сб Май 12, 2018 1:01 pm Ответить с цитатой Вернуться к началу

Непонял. Можно скриншотик?

_________________
ceterum censeo carthaginem esse delendam
Удачи. Олег.
Посмотреть профиль Отправить личное сообщение Посетить сайт автора
Convergence



Зарегистрирован: 15.02.2017
Сообщения: 36

СообщениеДобавлено: Сб Май 12, 2018 2:12 pm Ответить с цитатой Вернуться к началу

Пожалуйста.[/img]
Посмотреть профиль Отправить личное сообщение
Convergence



Зарегистрирован: 15.02.2017
Сообщения: 36

СообщениеДобавлено: Сб Май 12, 2018 2:19 pm Ответить с цитатой Вернуться к началу

Другими словами когда тянешь ползунок вправо отображается -0,01 потом должен по идее отображаться 0 (вместо него отображается значение -2.23517e-008), дальше должна отобразиться цифра 0,01 (вместо нее отображается 0.00999998), а дальше все отображается как и положено 0,02...0,03....0,04 и.т.д.
Посмотреть профиль Отправить личное сообщение
000
Site Admin


Зарегистрирован: 10.12.2007
Сообщения: 8457

СообщениеДобавлено: Сб Май 12, 2018 3:44 pm Ответить с цитатой Вернуться к началу

Хм. Даже не знаю что сказать. У меня такого нет. У меня именно с этим кодом
Var = Param("V", 0.05, -1, 1, 0.01);
отображается как положено.
-0,01 0 0,01...
Crying or Very sad

_________________
ceterum censeo carthaginem esse delendam
Удачи. Олег.
Посмотреть профиль Отправить личное сообщение Посетить сайт автора
Convergence



Зарегистрирован: 15.02.2017
Сообщения: 36

СообщениеДобавлено: Сб Май 12, 2018 9:05 pm Ответить с цитатой Вернуться к началу

Интересно. В любом случае спасибо, если решу проблему отпишусь. Удачи.
Посмотреть профиль Отправить личное сообщение
000
Site Admin


Зарегистрирован: 10.12.2007
Сообщения: 8457

СообщениеДобавлено: Сб Май 12, 2018 11:07 pm Ответить с цитатой Вернуться к началу

На всякий случай.
Ами 6.20.1 32
Вин 8 64

_________________
ceterum censeo carthaginem esse delendam
Удачи. Олег.
Посмотреть профиль Отправить личное сообщение Посетить сайт автора
Convergence



Зарегистрирован: 15.02.2017
Сообщения: 36

СообщениеДобавлено: Вс Май 13, 2018 1:19 pm Ответить с цитатой Вернуться к началу

Сегодня установил АmiBroker на другой ПК, с настройками и БД по умолчанию. Что могу сказать, судя по всему это программный баг. Обновлять программу пока не хочу, придется смириться с этой проблемой и жить дальше. Wink Как говориться, если не можешь изменить ситуацию можно изменить свое отношение к ней.
AmiBroker 5.90.1
Win 7 х86 х64
Посмотреть профиль Отправить личное сообщение
Показать сообщения:      
Начать новую тему  Ответить на тему


 Перейти:   



Следующая тема
Предыдущая тема
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах
Вы не можете вкладывать файлы
Вы не можете скачивать файлы


Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme :: Часовой пояс: GMT + 3

File Attachment © by Meik Sievertsen